Delayed updates

Incident Report for Shortcut

Resolved

We believe that this incident is resolved.
Posted Oct 04, 2024 - 08:24 EDT

Monitoring

We believe that we have addressed the underlying cause of the increased latencies and are monitoring the situation.
Posted Oct 03, 2024 - 17:46 EDT

Investigating

We are observing increased latencies throughout our system. Changes to your workspace may not be immediately apparent to other users.
Posted Oct 03, 2024 - 17:26 EDT
This incident affected: Web App.