Performance Degradation
Incident Report for Shortcut
Resolved
Identified the cause of the performance regression due to slow database queries. The application should be recovered now
Posted Sep 13, 2024 - 15:23 EDT
Investigating
We are currently investigating a severe performance regression across the application
Posted Sep 13, 2024 - 15:12 EDT
This incident affected: Web App and API.