Google Sheets integration is experiencing delays

Incident Report for Shortcut

Resolved

This incident has been resolved.
Posted Sep 01, 2021 - 10:17 EDT

Investigating

We are experiencing delays updating Google Sheets.
Delays are up to 2 hours.
We are currently investigating and expect it to be resolved by the end of day today.
Posted Aug 31, 2021 - 12:22 EDT