Application not loading for European customers

Incident Report for Shortcut

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 10:11 EDT

Monitoring

We have identified an issue with access key caching in our CDN, and have rolled out a fix.
Posted Jun 04, 2025 - 09:31 EDT

Investigating

European customers aren't able to load app.shortcut.com currently. We are investigating.
Posted Jun 04, 2025 - 09:09 EDT
This incident affected: Web App.