Application not loading for some EU customers

Incident Report for Shortcut

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 11:25 EDT

Monitoring

We've identified specific Fastly nodes (Fastly's "hel" region for Helsinki, Finland) that appear to have experienced this issue. We've forced purges of Fastly caches to restore Shortcut service. We've contacted Fastly to debug the issue further.
Posted Jul 31, 2025 - 09:41 EDT

Investigating

We are currently investigating this issue.
Posted Jul 31, 2025 - 01:15 EDT
This incident affected: Web App.