GSheet processing should have caught up. A few integrations had been disabled during investigation, we're looking to restore those integrations.
Posted Oct 03, 2025 - 09:38 EDT
Monitoring
Google Sheets processing has been re-enabled but is still behind. We're monitoring it's progress.
Posted Oct 01, 2025 - 10:12 EDT
Identified
Notifications for integrations should have caught up. Google Sheet processing has been disabled for the moment, we're working on a fix that will resume processing.
Posted Sep 30, 2025 - 16:33 EDT
Update
We are continuing to investigate this issue.
Posted Sep 30, 2025 - 14:46 EDT
Investigating
Our async processing infrastructure is running behind. Actively monitoring and investigating the root cause.
Posted Sep 30, 2025 - 11:36 EDT
This incident affected: Integrations (Email Notifications, Sentry Automations, VCS Integrations, Google Sheets Integration, Slack Integration, ProductBoard, Zendesk).