Some subsystems are experiencing delays

Incident Report for Shortcut

Resolved

This incident has been resolved.
Posted Mar 09, 2022 - 16:12 EST

Investigating

We are currently investigating this issue.
Posted Mar 09, 2022 - 16:06 EST